MailRecent
MailRecent
1.8

4.5

MailRecent free download for Mac

MailRecent

1.8
06 January 2019

Adds ability to copy to, move to, or go to recent Apple mailbox.

Overview

MailRecent adds "Copy to Recent," "Move to Recent," and "Go to Recent" menu items to Apple's Mail application.

These menu items contain dynamically-updated lists of recently used mailboxes. The number of mailboxes kept in the list is determined by the "Recent Items" setting in the General panel of the OS X System Preferences.

What's new in MailRecent

Version 1.8:

Note: Now requires macOS 10.14 or later

  • Updated for macOS 10.14.2 Mojave
  • Starting with macOS 10.4/Mojave, I am providing the plugin only. I cannot provide an installer, and you must perform a manual installation as described on the main page.
  • You might need to provide Full Disk Access for the Terminal application to successfully use the following commands. You should remove this elevated Terminal permission after you have issued the commands.
  • As of macOS 10.4/Mojave the command-line based customizations might or might not work for you.

34 MailRecent Reviews

See all

Rate this app:

Marchintosh
25 October 2016

Most helpful

Thank you for keeping this updated with new releases of macOS.
Like (1)
Version 1.6.2
Cheops
11 March 2019
Mr. Welch, thanks for updating this very handy utility!
Like
Version 1.8
JML54
12 January 2019
1.8 works fine with Mojave 10.14.2.
Like
Version 1.8
Stevie-Ackerman
05 November 2018
Not yet compatible with macOS 10.14 Mojave... Regretting the upgrade without checking my most used tools.
Like
Version 1.7
1 answer(s)
Jb4
Jb4
06 January 2019
Agree.... went through the installation steps and that great voice in the sky said:
"Not compatible with this version (Mojave) of the OS."
Like
RogerKatz
28 September 2017
Upon opening Apple Mail v11 (High Sierra) - I get an Alert (from Apple Mail) that MailRecent (v1.6.4) was Disabled because it is an Incompatible plug-in
Like
Version 1.6.4
1 answer(s)
Jimw
Jimw
30 September 2017
That is unfortunately correct. Until the developer updates it for High Sierra it is not going to work with it, unless someone else figures out how to patch the info file in its contents folder.
Like (1)
Marchintosh
27 September 2017
Love this software. Please update for High Sierra.
Like (1)
Version 1.6.4
RogerKatz
03 November 2016
It's handy, but its Installer didn't work for Sierra 10.12.1 - but I successfully installed it manually (per the developer's website instructions) (i.e., dragged its mail bundle to /Users/xxxxxx/Library/Mail/Bundles/.
Like
Version 1.6.2
Marchintosh
25 October 2016
Thank you for keeping this updated with new releases of macOS.
Like (1)
Version 1.6.2
Marchintosh
05 October 2015
Thank You!
Like
Version 1.5.3
sbchavel
21 October 2014
Broken by Yosemite. Argh.
Like
Version 1.4.5
1 answer(s)
gtrsteve
gtrsteve
24 October 2014
Update to 1.5
Like
robfol
27 February 2014
Updating my previous good review. Brilliant functionality although not as useful as MailFollowUp, for me installs and works perfectly every time. AND importantly swift updates for new OS versions
Like
Version 1.4.3
Free

4.5

App requirements: 
  • Intel 64
  • macOS 10.13.4 or later
Category: 
Developer Website: 
Download(1.6 MB)MacUpdateInstall with MacUpdate

Downloaded & Installed 16,578 times