7
Thank you for your review
Free
http://www.macupdate.com/download/34613/packages.dmg
Email me when discounted: 
Packages lets you create distribution and installation packages.

Who is it for?
Well, imagine you are a software developer who just completed a project and it's time to work on shipping it. Or you are an administrator and you need to deploy a plugin on the Mac computers of your network. Whenever you need to create an installation package or distribution for Mac OS X 10.5 or later, Packages is the powerful and flexible solution you're looking for.

With Packages, you can define which applications, bundles, documents or folders should be part of the payload of your installation packages and where more...

What's New

Version 1.1.1:
  • New: packagesutil tool to change numerous project settings from shell scripts or command line.
  • New: Support of QuickLook Plugins by the Smart Location Detector.
  • New: SCM Exclusion Rule now supports Git (.git, .gitignore) (for new projects created with version 1.1.1).
  • New: A package item can be exported as a Raw Package project from a Distribution project.
  • New: more...

Requirements

Mac OS X 10.5 or later

Similar Software

Open Comparison
Suggest Other Similar Software
Leave a Review

Packages User Discussion

Nobody has reviewed or commented on this app yet. Add your own comment and get a discussion going!
Sort by: Time | Smiles
chrisB Member IconReview+65
chrisB
+0

Great app especially for (signed) distributions and a very responsive developer in case of questions/issues.

Christian Buerli [macfix.de]

Reply0 replies
Version 1.1.1
Cerniuk Member IconReview+185
Cerniuk
+2

Seriously, how can such great software be free while a good amount of expensive commercial software is garbage?

Two package tools that are absolutely indispensable this one and Pacifist.

There needs to be a paypal link for donations for this bad-boy!

Reply0 replies
Version 1.1.1
Donmontalvo Member IconReview+1288
Donmontalvo
+3

Excellent application, I wish JAMF would buy this! :)

Don

Reply0 replies
Version 1.1.1
Philip-Petev Member IconReview+6
Philip-Petev
+1

Can anyone tell me how to set up the dependencies between the packages inside the metapackage? I set one package to be selected if other is selected, but in the compiled package nothing is happening. Is this Dependencies Editor working at all?

Reply0 replies
Version 1.1.1
Slimjids Member IconComment+0
Slimjids
+0

I keep getting ''The operation couldn’t be completed. (com.apple.installer.pagecontroller error -1.)'' after i try to run packages that i've built.The Only way it seems to go away, is if i create a new project in a different directory and start fresh.This has happened twice so i'm back to iceberg.

Reply1 reply
Version 1.1
Philip-Petev
+0

Same here. This program is buggy.

sjk Member IconComment+996
sjk
+0

No WHAT'S NEW at MU (yet); release notes are here:

http://s.sudre.free.fr/Software/Packages/release_notes.html

Reply2 replies
Version 1.0.3
Slimjids
+0

Can anyone supply an earlier version like 1.0.9.I seem to be having some issue with this (1.1) version

sjk
+0

Ask the developer?

Roro01 Member IconComment+0
Roro01
+0

The installer installs all the bits but the application itself. iMac Intel 10.6.4

Reply3 replies
Version 1.0.1
Whitebox (Developer)
+1

Considering that:

- the application is in the payload of the Installer (that can be checked with Pacifist)
- it works fine on my Mac for a clean install or an update on Mac OS X 10.6.4.

I would suggest checking, with Spotlight for instance, that you did not have a previous version of the application that has been moved outside the /Applications folder. The installation "package" for Packages looks for previous versions of the application and update the first one it finds.

Roro01
+0

Yes, the application is in the payload of the Installer. After installing I didn't find it in the application folder so I used Find Any File to search for it on Macintosh HD but to no avail. Finally I used unpkg to retrieve it from inside the installer. The installer definitely doesn't install the application and I don't know why.

Whitebox (Developer)
+1

The Installer log files may provide an explanation.

Moocan Member IconComment+11
Moocan
+1

Packages is so easy to use and very useful.
Great tool. Thanks to dev for making this for free.

1 - just have a little trouble with adding reference to a standard folder as /System/Library/CoreServices (without all files in it) in the same way to the /System/Library/Extensions.

2- does not seems to save payload default destination. always reset to / when project is opened.

This is maybe due to a bad use by me !

Reply1 reply
Version 1.0
Whitebox (Developer)
+3

1. Select the /System/Library folder in the Contents list and choose Hierarchy > New Folder. Be sure to check the permissions

2. Ouch. It is not fixed in 1.0.1 as I don't read comments on MacUpdate (or equivalent sites) as often as I read my mailbox. I will make sure it's addressed in 1.0.2.

Cabbage Member IconComment+10
Cabbage
+0

Does this mean Iceberg is dead?

Reply1 reply
Version 1.0
Packagesdev
+1

No, it just means that Iceberg will not support flat packages and distributions.

user icon+138
Vitu
Version 1.1
user icon+0
dbailey
Version 1.0.9
user icon+4
Sagoisslu
Version 1.0.7
> 5 7

Ratings

Overall
(7)
Current Version (1.x)
(7)

Details

Downloads 12,880
Version Downloads 6,811
License Free
Date 08 Aug 2012
Platform Intel 64 / OS X / PPC 32 / Intel 32 / PPC 64
Price Free
Learn how MacUpdate Desktop makes installing apps from MacUpdate.com one-click easy.
Next time, install Packages with 1-click

Learn how MacUpdate Desktop can install apps on MacUpdate with the simple click of the Install apps with MacUpdate Desktop icon. Plus, keep all your apps updated. Play video...