Adaptec PowerDomain 29160N SCSI Driver
Adaptec PowerDomain 29160N SCSI Driver
1.2

5.0

Adaptec PowerDomain 29160N SCSI Driver free download for Mac

Adaptec PowerDomain 29160N SCSI Driver

1.2
19 December 2002

Mac OSX driver for Adaptec expansion cards.

Overview

Note:This app is no longer under development, and it is no longer available for sale.


Adaptec PowerDomain 29160N for Mac OS X contains MacOS X compatible drivers for the internal Adaptec cards.

5 Adaptec PowerDomain 29160N SCSI Driver Reviews

Rate this app:

Anonymous
24 October 2002

Most helpful

so far... won't work well with Quick Silver 933 and OSX!
Like
Version 1.1
lakshman
14 August 2005
we update the adaptec 29160N driver for Mac Os 10.3.9
Like
Version 1.2
1 answer(s)
Hank2
Hank2
28 January 2007
Who updated it, and is it updated for OSX as well? I was supposed to get email from Adaptec if they ever supported their external PC-card adapter, and just stumbled over this very old ambiguous posting. Anyone know if it finally works?
Like
Version 1.2
Anonymous
11 July 2004
I wonder what kind of IDIOTS you have seen! It works like charm on OS X 10.3.4 We have two of this cards ZERO problems!
Like
Version 1.2
1 answer(s)
Anonymous
Anonymous
31 March 2005
Has anyone got this card to work with a G5 10.4? Cheers.
Like
Version 1.2
Neal Geiger
24 January 2004
I have a 500 G3 B&W with a 29160N scsi card that worked great for a couple of years as long as I was in OS9. Then I moved to OSX. The Adaptec card simply does not work in the OSX environment.. I downloaded the new drivers from Adaptec (they even have a new beta out since January) but it still, will not allow my second wide scsi drive to be seen. Adaptec did offer support for $69 per issue (a little pricey for an old machine and no guarantee of a solution). I visited a Mac repair store and they just shook their heads and said the Adaptec cards will not work with any OSX product-period. They did suggest buying a new harddrive because it will be cheaper than another scsi card. So, based on this experience, I never intend to buy another Adaptec product again.
Like
Version 1.2
22 November 2003
Doesn't seem to work with Panther?
Like
Version 1.2
Anonymous
24 October 2002
so far... won't work well with Quick Silver 933 and OSX!
Like
Version 1.1
Free

5.0

App requirements: 
  • PPC 32
  • or later
Category: 
Developer Website: 
Download(70 KB)MacUpdateInstall with MacUpdate

Downloaded & Installed 9,278 times