Double Commander

Download the old version of Double Commander for Mac

If you experience any compatibility issues with Double Commander for Mac, consider downloading one of the older versions of Double Commander. MacUpdate stores previous versions of Double Commander for you since v. 0.8.4.

Download the current version

Older versions of Double Commander for Mac