Apple iMac Graphic FW Update
Apple iMac Graphic FW Update
3.0

0.0

Apple iMac Graphic FW Update free download for Mac

Apple iMac Graphic FW Update

3.0
24 August 2011

Fixes iMac graphic issues.

Overview

Apple iMac Graphic FW Update fixes a graphics issue that may cause an iMac to hang under certain conditions.

Do not shut off the power on your iMac during this update. Loss of power could result in your iMac failing to start up.

What's new in Apple iMac Graphic FW Update

Version 3.0:
  • Release notes were unavailable when this listing was updated.

1 Apple iMac Graphic FW Update Reviews

Rate this app:

Acuraice
24 August 2011

Most helpful

why can't i ever install any of these firmware updates on my iMac?????? i understand with the others that they are for specific iMac systems,but this one in particular states that it is for ALL users with an intel iMac running 10.7 or later,which i clearly have.
Like
Version 3.0
Acuraice
24 August 2011
why can't i ever install any of these firmware updates on my iMac?????? i understand with the others that they are for specific iMac systems,but this one in particular states that it is for ALL users with an intel iMac running 10.7 or later,which i clearly have.
Like
Version 3.0
8 answer(s)
RunHomeSlow
RunHomeSlow
24 August 2011
Neither can i :-) iMac G5/2.8/20in, running 10.7.1
Like (1)
2stepbay
2stepbay
24 August 2011
Are you having graphics problems? If not, be happy your machine is not included.
Like
Rusto
Rusto
25 August 2011
@ RunHomeSlow: did you not read the Requirements: INTEL among them?
Like
RavenNevermore
RavenNevermore
25 August 2011
Your machine doesn't need it. They want all users to use it to see if you need it. Mine didn't need it either. :)
Like
I(pod)mac
I(pod)mac
25 August 2011
@RunHomeSlow: how can you have installed Mac OS X Lion on your computer, since G5 processor isn't included between those supporting that system? Do you have perhaps made confusion between G5 and i5?
Like
RunHomeSlow
RunHomeSlow
25 August 2011
To all reply to me... is there G6 out there? i think all G5 are Intel!! no? 2.8Ghz intel Core 2 Duo / 4gig of Ram / 10.7.1 under at the job: 2 ghz intel core 2 duo / 3 gig of ram / 10.7.1
Like
RavenNevermore
RavenNevermore
25 August 2011
@RunHomeSlow, no, you have an Intel Core 2 Duo CPU. The G5 was an IBM PowerPC (PPC) 970 processor. Apple has dropped support for PPC with Lion. The G5 was discontinued in 2006.
Like (1)
RunHomeSlow
RunHomeSlow
25 August 2011
@ Davidravenmoon thanx for clarifiyng all that :-)
Like
Free

0.0

App requirements: 
  • Intel 64
  • Intel 32
  • Mac OS X 10.7.0 or later
Category: 
Developer Website: 
Download(494 KB)MacUpdateInstall with MacUpdate

Downloaded & Installed 1,032 times