Apple iMac Graphic FW Update
Apple iMac Graphic FW Update
2.0

5.0

Apple iMac Graphic FW Update free download for Mac

Apple iMac Graphic FW Update

2.0
08 June 2011

Fixes issue that may cause iMacs to hang during startup.

Overview

iMac Graphic FW Update

fixes an issue that in rare cases may cause an iMac to hang during startup or waking from sleep.

Do not shut off the power on your iMac during this update. Loss of power could result in your iMac failing to start up.

3 Apple iMac Graphic FW Update Reviews

Rate this app:

Acuraice
08 June 2011

Most helpful

Hmm...what do ya know,yet another imac firmware graphics update that apparently my 24 inch imac doesnt need!!! so friggin stupid,i have had my imac for 2 years now and i think this is the 3rd or 4th firmware or graphics error update,but havent been able to apply any since the installer continually tells me i do not need this update! i sent the update to my brother who has a brand new 27 inch imac,and it also told him he does not need the update! TOTALLY USELESS!!!!
Like (1)
Version 2.0
Steve-R
10 June 2011
Go to the Appple on the menu bar, About This Mac, click on More in the open window, choose Graphics/Displays. If you have either ATI Radeon HD 2600 Pro or HD 2400 XT *and* if you have a 20 or 24-inch aluminum iMac, then you may need to install this update. That said, I wonder if this is Apple's 'get out of jail free' card for all of us who have complained that our iMacs suddenly and randomly shut off for no apparent reason. I ended up taking mine in for an Applecare repair for that exact reason, and ended up getting a new LCD because of what I had assumed was smoke residue on the inside of the glass.
Like
Version 2.0
Acuraice
08 June 2011
Hmm...what do ya know,yet another imac firmware graphics update that apparently my 24 inch imac doesnt need!!! so friggin stupid,i have had my imac for 2 years now and i think this is the 3rd or 4th firmware or graphics error update,but havent been able to apply any since the installer continually tells me i do not need this update! i sent the update to my brother who has a brand new 27 inch imac,and it also told him he does not need the update! TOTALLY USELESS!!!!
Like (1)
Version 2.0
2 answer(s)
Adreitz
Adreitz
09 June 2011
I don't understand why you're upset. DId you *want* to need this update? Isn't it better that your computer works properly and you don't need it? Yes, Apple should provide more detail on what configurations the update applies to and what problems it fixes. But even without that info, this update applies to someone. Just not you.
Like (3)
RavenNevermore
RavenNevermore
09 June 2011
@Adreitz, go to his profile and read his comments. They are mostly just like this... this is useless, this is stupid, this and that makes him angry. Pretty damn funny!
Like (4)
Midipro
08 June 2011
Which iMac is this update good for?
Like
Version 2.0
5 answer(s)
Mikaelf
Mikaelf
08 June 2011
use the software update on your iMac...I'm thinking that's how get it (the right way) or go check....tada....apple.com:-)
Like
Midipro
Midipro
08 June 2011
Hi Mikaelf and thank you for the fast reply. I tried the software update and nothing. I went to apple.com and there were no specifics on the update. I still downloaded it thou. Once i double-clicked the installer, a message displayed saying this iMac doesn't have the hardware required. So, in my case i don't need it. Thanks again.
Like
RavenNevermore
RavenNevermore
09 June 2011
You would think they would say, right? Very unusual from Apple. But my 2009 iMac didn't need it, so that's a good thing. I never put it to sleep anyway.
Like
Midipro
Midipro
09 June 2011
@ Davidravenmoon: Agreed. If my mac doesn't need it, I rather not apply the update. Something less for me to worry about. About Acuraice, I have no clue about his issue. Why would he want the update if it's not needed? That's just stupid. Apple could have posted some more info about the updated and which iMac was targeted too thou, oh well. Next round I guess.
Like
Steve-R
Steve-R
10 June 2011
Apple iMac Graphics Firmware Update 2.0 - For 20 and 24-inch aluminum iMacs with ATI Radeon HD 2600 Pro or HD 2400 XT. I have no idea why this expanded info shows up on an RSS feed but not on the website.
Like
Free

5.0

App requirements: 
  • Intel 32
  • Mac OS X 10.6.8 or later
Category: 
Developer Website: 
Download(662 KB)MacUpdateInstall with MacUpdate

Downloaded & Installed 1,054 times