Ruby One-Click Installer
Your rating: Now say why...

0

Simple way to equip your pre-Leopard Mac with Ruby.   Free
Add to my Watch List
Email me when discounted
Ruby One-Click Installer... This package is the most simple way to equip your pre-Leopard Mac Apple OS X System with Ruby - similar to the Windows Ruby One-Click Installer. It replaces the broken Readline library, updates to a current version of SQLite3 and prepares your OS X for Rails, which needs at least Ruby 1.8.4 to run. The current Ruby Version is 1.8.6 (1.8.5 is recommended for Rails) and Rubygems 0.9.4.

Note: This is NOT needed for Mac with Leopard. Leopard already inlcudes a recent version of Ruby and now includes Rails.
What's New
Version 1.8.7: Release notes were unavailable when this listing was updated.
Requirements
Intel, Mac OS X 10.5 or later








    Be the first to recommend a similar software title.
Ruby One-Click Ins... User Discussion (Write a Review)
ver. 1.x:
Your rating: Now say why...
Overall:

sort: smiles | time
burypromote
+1

+44
I(pod)mac commented on 03 Nov 2009
Ruby One-Click Installer 1.8.7 is only for Intel Macs.
PPC users have to build it from source: you can find how to do it at the following url:
http://danbenjamin.com/articles/2008/02/ruby-rails-leopard
[Version 1.8.7]


burypromote

+37
Tuishimi commented on 12 Feb 2008
Just an FYI... 10.5 comes with Ruby/ROR.
[Version 1.2]

1 Reply

burypromote

+37
Tuishimi replied on 12 Feb 2008
Yes, I know it says "pre-leopard" but people might miss that. And if you install over the version that comes w/Mac OS X 10.5 you could potentially hose something.
There are currently no troubleshooting comments. If you are experiencing a problem with this app, please post a comment.

There are currently no ratings. Write a comment or review now.

Downloads:1,686
Version Downloads:905
Type:Development : Compilers
License:Free
Date:02 Nov 2009
Platform:Intel 32 / OS X
Price:Free0.00
Overall (Version 1.x):
Features:
Ease of Use:
Value:
Stability:
Displaying 1-2 of 2
-
-
-
Please login or create a new
MacUpdate Member account
to use this feature
Watch Lists are available to
MacUpdate Desktop Members
Upgrade Now
Install with MacUpdate Desktop.
Save time moving files & cleaning
up space wasting archives.
Ruby One-Click Installer... This package is the most simple way to equip your pre-Leopard Mac Apple OS X System with Ruby - similar to the Windows Ruby One-Click Installer. It replaces the broken Readline library, updates to a current version of SQLite3 and prepares your OS X for Rails, which needs at least Ruby 1.8.4 to run. The current Ruby Version is 1.8.6 (1.8.5 is recommended for Rails) and Rubygems 0.9.4.

Note: This is NOT needed for Mac with Leopard. Leopard already inlcudes a recent version of Ruby and now includes Rails.


- -