MailFollowUp
MailFollowUp
2.0.1

4.4

MailFollowUp free download for Mac

MailFollowUp

2.0.1
11 January 2019

Adds a follow up item to emails and contextual menus in Apple Mail.

Overview

The MailFollowUp bundle adds a "Follow Up" item to the Message and contextual menus (and optional toolbar item) of Apple's Mail application that allows you to compose (and then send) a quoted version of the original message to all of the original recipients, keeping the To, CC, and BCC addresses exactly as they appeared in the original message.

What's new in MailFollowUp

Version 2.0.1:

Note: Now requires macOS 10.14.2 or later

Fixed:
  • For those who had issues, should now load under macOS 10.14.2 (Mojave)

46 MailFollowUp Reviews

See all

Rate this app:

evilinstone
08 September 2009

Most helpful

Please update this plug-in for SL. Thanks! I can't leave without this plug-in!
Like (3)
Version 1.3.1
simon-156
13 February 2019
what is the difference between this app and the mailbuttler follow up? https://support.mailbutler.io/knowledge-base/set-up-a-follow-up-reminder/ (I think the mail butler is to expensive, since that is the only thing I would like to do)
Like
Version 2.0.1
Macsmurf
11 January 2019
Excellent! 2.0.1 installs and works for me now! Thank you, Greg, for finding the time to look into the issue some of us were having with 2.0.0.
Like (1)
Version 2.0.1
4 answer(s)
Neutra
Neutra
11 January 2019
2.0.1 installs fine (2.0.0 didn't) but every time I try and use MFU it crashes Mail. Darn! It was looking good there for a minute...
Like
Stevie-Ackerman
Stevie-Ackerman
11 January 2019
Hurrah... The beloved MailFollowUp is working again... Mail version 12.2 (3445.102.3)
Like
MichaelHaeusler
MichaelHaeusler
12 January 2019
Yep, crashes too on my Mac. When I delete the plugin preferences in Mail's sandbox container, FollowUp doesn't crash Mail anymore, but as soon as I write new preferences for the follow-up prefix, the crashes return.
Like
Neutra
Neutra
12 January 2019
Using Greg's guidance from his MailFollowUp webpage I set the prefix to "Re: ". With that setting there is no crashing. If I try to set it to "Follow-up: " then goes back to crashing each time I invoke it. So, working but no option to change the prefix.
Like
Capitalj
11 January 2019
2.0.1 works for me in Mail 12.2, Mojave 10.14.2. I've missed this, and I'm not bothered by the manual install.
Like (1)
Version 2.0.1
Murryfax
06 January 2019
Just installed the new version of MailFollowUp (2.0), which I have been waiting for a long time. However, Mail claims it is not compatible with the current Mail version… The rating is of course for earlier versions which did work very well (although I have always had to do a manual install, even when there was an installer application)
Like (2)
Version 2.0
4 answer(s)
Neutra
Neutra
06 January 2019
Same here: followed instructions but Mail doesn't like it. Greg's other bundle update; MailRecent works fine with Mail 12.2...
Like (2)
Stevie-Ackerman
Stevie-Ackerman
07 January 2019
Same here... MailRecent 1.8... YES... MailFollowUp 2.0... Not compatible with Mail version 12.2 (3445.102.3).
Like
Macsmurf
Macsmurf
07 January 2019
I'm also having the same issue, emailed Greg about it: his response is "I’m not sure what’s up w/ MF. It works for me and many others, but not for some. I don’t have the ability to chase down the issues at this time—not sure when I will have time. Make sure you check the install instructions carefully."
Like
markrfriedman
markrfriedman
08 January 2019
I followed Greg's direction for the manual install, but mail rejected mine, too.
Greg has given freely of his time for a long and I'm reluctant to say anything negative about his work, but this release needed testing on someone else's machine.
Like
Stevie-Ackerman
07 November 2018
Not yet compatible with macOS 10.14 Mojave... Regretting the upgrade without checking my most used tools.
Like
Version 1.9
robfol
15 October 2017
Update for High Sierra: Send Greg a beer! Essential Mail Plugin!!!!
Like (1)
Version 1.9
Kobalt
14 December 2016
Yes! Greg's already done the update for Sierra 10.12.2. Big thanks! http://www.cs.unc.edu/~welch/MailFollowup/media/MailFollowUp_1.8.3.dmg.zip
Like (1)
Version 1.8.2
Kobalt
27 September 2016
Yay! Version 1.8.1 works in Mail 10 (Sierra)! Thanks for doing the update. Have a beer or two on me, Greg.
Like
Version 1.8.1
Kobalt
16 September 2016
I like this plugin and am super sad that it doesn't work with Mail 10 (Sierra) at the moment.
Like
Version 1.8
Frankns
28 March 2016
Wonderful to have this and "MailRecent" back on my machine ... Put a smile on my face for a Monday morning.
Like
Version 1.8
Free

4.4

App requirements: 
  • Intel 64
  • macOS 10.13.4 or later
Category: 
Developer Website: 
Download(1.6 MB)MacUpdateInstall with MacUpdate

Downloaded & Installed 29,235 times