Thank you for your review
Developer website: 

Lenscare moves depth of field and out of focus generation to post production. If you need high quality camera blurs with the flexibility of 2d post processing, Lenscare is a great choice. It can get you rid of long extra 3d rendering times. The key aspect during the development of these filters was to match the real thing as good as possible. Lenscare is available as plugins for Adobe After Effects and Photoshop compatible programs.

What's New in Lenscare

Version 1.49:
  • Fixed crash that occurred in newer CC versions, usually when scrubbing parameters.
  • Fixed problem in CS5.5 and before where a After Effects error dialog would pop up all the time.

Requirements for Lenscare

  • OS X 10.5.8
  • After Effects or Premiere CS5.5
Similar Software
Suggest other similar software
Create a collection and add  to it.
Like this app? Be the first to add it to a collection! Create a Collection by bringing together complementary apps that have a common theme or purpose, then share it and discover new collections! + Create a Collection

Lenscare User Discussion

Ratings
Overall
(0)
Current Version (1.x)
(0)
Details
Downloads 2,336
Version Downloads 90
License Demo
Date 08 Apr 2019
Platform OS Classic / OS X / Intel 32
Price $199.00
To leave a comment, you need to be logged in.
reviews_anchor
Sort by: Time | Smiles
Lenscare needs a rating. Be the first to rate this app and get the discussion started!
MacUpdate Promo