Mx
Downloads: 125
Posts: 26
Smile Score: +10
Mx's Posts
Average Rating from Mx:
(19)

sort: smiles | time

Mx rated on 14 Apr 2014
[Version 2.0.16]



burypromote
Mx commented on 20 Jul 2011
Aperture 3.1.3 requires Snow Leopard (10.6). It is not “10.5.8 or 10.6.2 or later.”
[Version 3.1.3]




Mx rated on 19 Jul 2011
[Version 4.2.0]




Mx rated on 19 Jul 2011
[Version 1.7.3]




Mx rated on 19 Jul 2011
[Version 3.10]




Mx rated on 19 Jul 2011
[Version 1.5.8]




Mx rated on 19 Jul 2011
[Version 1.5]




Mx rated on 19 Jul 2011
[Version 3.4.1]




Mx rated on 19 Jul 2011
[Version 11.006]




Mx rated on 19 Jul 2011
[Version 2.5.1.2502]



There are currently no troubleshooting comments by this member.

Displaying 1-10 of 22
1 2 3 >
Please login or create a new
MacUpdate Member account
to use this feature


- -