James Steckel
Downloads: 27
Posts: 6
Smile Score: +5
About Me
I am a Free member


Visit Stats
Last Visit: Today
Member Since: 21 Dec 2008
Profile Views: 481

James Steckel's Posts
Average Rating from James:
(4)

sort: smiles | time
burypromote

Jimsinsd reviewed on 15 Apr 2014
Google Drive is NOT compatible with all Intel Macs running OS X 10.6.8. Don't let their specs fool you. There have been many of us trying to get this fix but Google has simply been unresponsive and refuses to change their specs when they know the specs are wrong.

I went to DropBox and find it much more usable and stable.
[Version 1.15.6464.0228]




Jimsinsd rated on 10 Apr 2014
[Version 4.2.3.3]



burypromote
+2

Jimsinsd reviewed on 08 Feb 2014
Google Drive v1.13 was incompatible with older 32 bit Intel Macs and the bug has not been fixed with the new Google Drive 1.14.6059.0644. Users posted immediately on Dec 13, 2013 and submitted bug reports. No bug report was ever answered. BEWARE: Google Drive crashes instantly on older Macs and Google engineers will not fix it.
[Version 1.14.6059.0644]



burypromote
+1
Jimsinsd commented on 30 Dec 2013
I would like to alert MacUpdate users that the current version of Google Drive v1.13 is incompatible with older 32 bit Intel Macs despite Google listing it as compatible. It crashes almost immediately and will not sync files. Complicating the situation for 32 bit Intel Mac users is Google invasively upgrades v1.12 to v1.13 without the users knowledge or permission. There has been a thread on Google Forums (https://productforums.google.com/forum/#!msg/drive/Ks8CTmiM510/KmwER1ZHEtoJ) about this problem since Dec 13th, the day it was released. The posters have been able to disrupt Google updating to v1.13 and directions can be found on the thread along with a link to download v1.12. Google has been unresponsive to this problem and the forum as well as messages with crash and machine details sent to them from various posters. Please beware of the big brother.
[Version 1.13.5782.0599]



burypromote
+1
Jimsinsd commented on 14 Dec 2013
Everyone should know that MacUpdate's online Xmarks for Safari v2.0.6 is behind the times. Xmarks has just released v2.0.9 (http://download.xmarks.com/download/all). It has many bug fixes and works great now with my old core duo, 2006 first Intel edition, OS X 10.6.8 iMac as well as my OS X 10.9 MacBook Pro. I had the pleasure this week of testing pre-release versions for them. Check it out.
[Version 2.0.6]



burypromote
+1

Jimsinsd reviewed on 01 Aug 2010
This is the best software on the market for both Macs and PCs. There is a significant amount of features built in and now has the ability for custom graphics. The authors are responsive to your needs and usually answer your question posted on their forums. I have LWC2 installed and it simply works....it works all the times.
[Version 2.0.0]



There are currently no troubleshooting comments by this member.

Displaying 1-6 of 6
Please login or create a new
MacUpdate Member account
to use this feature


- -