George Paphitis
Downloads: 0
Posts: 25
Smile Score: +5
About Me
I am a Free member
Gender: Male


Visit Stats
Last Visit: 148 days ago
Member Since: 24 Jul 2008
Profile Views: 1,744

George Paphitis's Posts
Average Rating from George:
(1)

sort: smiles | time
burypromote
George-Paphitis commented on 21 Feb 2013
Weatherman 2.5.2 keeps crashing today. Running it on OS 10.6.8
Sent crash reports to dean@afterten.com. No response. Anyone else having same issues?
[Version 2.5.2]



burypromote

George-Paphitis reviewed on 01 Nov 2012
Snow Leopard users beware. This version wouldn't open with OS 10.6.8. I contacted the developer who is aware of the problem. It is to be corrected in version 2.7.1
[Version 2.7]



burypromote
George-Paphitis commented on 28 Jul 2009
Does Perian 1.1.4 resolve the conflict with iChat AV seen with ver 1.1.3 where you cannot see the person you are connected to during a video chat but they can see you? This did not occur with ver 1.1.2 which I reverted to. Both the Perian developers and Apple are finger pointing at each other as to who is to blame.
[Version 1.1.4]



burypromote
+1
George-Paphitis commented on 07 Apr 2009
Recognizes my iPod Photo but not my iPod Video 5.0g. If I manually type in the Serial it gives me the date of manufacture of the iPod video but not where it was made.
[Version 2.4]



burypromote
+1
George-Paphitis commented on 06 Sep 2004
Tried using MUMenu 2.1.1 on my G4 Yikes with OS 10.2.8 but I ran into the following problems:
1) Quits unexpectedly at times
2) Not running when computer awakes from sleep
3) Preferences don't stick after restarts, or relaunching of the application

For me I had to revert back to v. 1.2 Fortunately I had an archived copy since it is no longer available from MacUpdate.
Also for me, and 4% of the other males out there with red/green problems, the red font to indicate a highlighted item (instead of the dash as in v.1.2) is very hard to distiguish from the black.
[Version 2.1.1]



burypromote
George-Paphitis had trouble on 05 Nov 2009
It is 1:55 PST and MU Menu is not updating either by manual or periodic setting. I concur with Archmission something is a miss since yesterday when I first noticed it. I am using OS 10.4.11 on an early Intel iMac.
[Version 2.1.2]



burypromote
George-Paphitis had trouble on 26 Jan 2009
I am the owner of a license from a previous version. I tried contacting the developer by e-mail for a new serial using the address on his website jorisveruurt@planet.nl but the e-mails bounce. I tried three times. I am at a loss of what to do next. Hopefully, he reads these reviews and may respond.
[Version 4.3.4]



burypromote
George-Paphitis had trouble on 31 Oct 2007
I tried to upgrade from ver. 1.6.4 on an Intel iMac running OS 10.4.10 Inspite of removing older version and deleting the preference file I could not get the newer version to display Global Preferences in the Preference Pane menu. The only function turning the Powermate was to change system volume. I could not scroll in web browser. In addition, this version does not support Unsanity's Cee Pee You. I reverted back to ver. 1.6.4 and all is back to normal again. As they say: "If it ain't broke don't fix it!"
[Version 2.1]


1 Reply

burypromote

+5
George-Paphitis commented on 15 Nov 2007
I have the driver installer v. 1.6.4, but I have no way to contact you. You might try contacting Griffin directly either by this webform or by telephone on their site:

http://www.griffintechnology.com/about/contact/
burypromote
George-Paphitis had trouble on 04 Sep 2007
This version worked well until today.Now the widget displays no lines and preferences are grayed out and unchangeable. The NextBus.com website is up and running. Have there been changes to that site which have interfered with the widget parsing the data?
[Version 1.0.4]



burypromote
George-Paphitis had trouble on 13 Apr 2007
Can't install this version of Flash on my G3 iBook with OS 10.3.9 I keep getting messages that a browser is running when I know none is. I tried restarting, repairing permissions, even a safe boot and I still get that message. Anyone have any other suggestions? Current flash version which works is 9.0.28, but I am reluctant to uninstall it because I have no backup.
[Version 9.0.45]



burypromote
George-Paphitis had trouble on 21 Aug 2006
gDisk 0.5 will not launch with Intel iMac
[Version 0.5]



burypromote
George-Paphitis had trouble on 01 May 2006
Application won't launch with OS 10.2.8 or 10.3.9
[Version 1.0]



burypromote
George-Paphitis had trouble on 04 Apr 2006
I could not run G-Force 3.5 at all on OS 10.2.8 And what was worse to revert to the G-Force 3.1.3 Platinum I had to manually remove all the newly installed files before I could do the reversion since the installer would not let me install an older version over the new one.
[Version 3.5]



Displaying 1-5 of 5
Displaying 1-8 of 8
1 >
Please login or create a new
MacUpdate Member account
to use this feature


- -