Thank you for your review
Developer website: 
Important: You must download the OSX Install after the updater patch.

The Myst III files for OS X require your Myst III version to be v1.22 and your OS to be 10.1. After updating your OS with Apple's OS X update to 10.1, you will need to install Myst III: Exile and the v1.22 upgrade. Though you may be in OS X, the upgrade will install a new shortcut to Myst III on the desktop of your OS 9.1 partition. This can be copied over to your OS X desktop.

Requirements

Mac OS X 10.1, OS 9.1 partition, Myst III v1.22 English.

Similar Software

Suggest other similar software
Create a collection and add  to it.
Like this app? Be the first to add it to a collection! Create a Collection by bringing together complementary apps that have a common theme or purpose, then share it and discover new collections! + Create a Collection

Myst III Updater User Discussion

Ratings

Overall
(0)
Current Version (1.x)
(0)

Details

Downloads 5,957
Version Downloads 2,367
License Updater
Date 04 Oct 2001
Platform OS Classic / OS X / PPC 32
Price Free
To leave a comment, you need to be logged in.
reviews_anchor
Sort by: Time | Smiles
Myst III Updater needs a review. Be the first to review this app and get the discussion started!
Myst III Updater needs a rating. Be the first to rate this app and get the discussion started!
MacUpdate Promo