Adobe Application Manager
Your rating: Now say why...

0

Patch Adobe CS5.5 or later with Application Manager.   Updater
Add to my Watch List
Email me when discounted
Adobe Application Manager's patch will install the Adobe Application Manager that is included with Creative Cloud, Creative Suite 6, Creative Suite 5.5 products. It is only necessary to run this patch if you are receiving one of the following error messages:
  • Adobe Application Manager is needed to update your product.
  • Adobe Application Manager is needed to start your trial.
For additional information on this issue, see, "Error, "Adobe Application Manager is needed..." when launching or using Creative Suite 6, Creative Suite 5 " (cpsid_84344.)
What's New
Version 8.0.0.22:

This patch will install the Adobe Application Manager that is included with Adobe Creative Cloud, Adobe Creative Suite 6, Adobe Creative Suite 5.5 products. It is only necessary to run this patch if you are receiving one of the following error messages:

  • Adobe Application Manager is needed to update your product.
  • Adobe Application Manager is needed to start your trial.
For additional information on this issue, see "Error, "Adobe Application Manager is needed..." when launching or using Creative Suite 6, Creative Suite 5 " this page.

Version 8.0.0.22:

This patch will install the Adobe Application Manager that is included with Adobe Creative Cloud, Adobe Creative Suite 6, Adobe Creative Suite 5.5 products. It is only necessary to run this patch if you are receiving one of the following error messages:

  • Adobe Application Manager is needed to update your product.
  • Adobe Application Manager is needed to start more...
Requirements
  • Intel
  • OS X 10.5.7 or later
  • One of the following:
    • Adobe Creative Suite 5.5
    • Adobe Creative Suite 6
    • Adobe Creative Cloud products



MacUpdate - Adobe Application Manager



    Be the first to recommend a similar software title.
Adobe Application... User Discussion (Write a Review)
ver. 8.x:
Your rating: Now say why...
Overall:
(1)

sort: smiles | time
burypromote

+51
Der~bot~haus commented on 05 Oct 2012
Typical "Your updater needs updating to ∞". Just ran my 6 updater and no update for the updater.
[Version 7.0.0.34]


burypromote
+1

+37

Sanchai reviewed on 04 Oct 2012
No version 7.0.0.34 as stated here. Try download from Adobe site and serach then, found only Adobe Application Manager 6.2 for Mac.

Where is 7.0.0.34? Fix please
[Version 7.0.0.34]


burypromote
+3

+375
B. Jefferson Le Blanc commented on 04 Oct 2012
Talk about confusing. The Adobe Applications Manager alias in my Applications folder actually points to an app called AdobeCreativeCloudClient, which is in the same sub-folder as an item named AdobeApplicationManager. This update changes the version number on AdobeCreativeCloudClient only. When I launch AdobeCreativeCloudClient, I actually get the Applications Manager - which may be because I don't have a creative cloud account. Adobe probably has their reasons for this cockeyed nomenclature; no doubt they don't intend for us to access these apps directly. Or maybe they just enjoy tying themselves in knots.
[Version 7.0.0.34]


There are currently no troubleshooting comments. If you are experiencing a problem with this app, please post a comment.


+36

Zincker rated on 19 Jun 2013

[Version 7.0.0.414]


Downloads:99,373
Version Downloads:7,722
Type:Multimedia Design : Author Tools
License:Updater
Date:20 Mar 2014
Platform:Intel 32 / OS X
Price:Free0.00
Overall (Version 8.x):
Features:
Ease of Use:
Value:
Stability:
Displaying 1-3 of 3
Displaying 1-1 of 1
-
-
-
Please login or create a new
MacUpdate Member account
to use this feature
Watch Lists are available to
MacUpdate Desktop Members
Upgrade Now
Install with MacUpdate Desktop.
Save time moving files & cleaning
up space wasting archives.
Adobe Application Manager's patch will install the Adobe Application Manager that is included with Creative Cloud, Creative Suite 6, Creative Suite 5.5 products. It is only necessary to run this patch if you are receiving one of the following error messages:
  • Adobe Application Manager is needed to update your product.
  • Adobe Application Manager is needed to start your trial.
For additional information on this issue, see, "Error, "Adobe Application Manager is needed..." when launching or using Creative Suite 6, Creative Suite 5 " (cpsid_84344.)


- -