Back to GrowlMail page
GrowlMail free download for Mac

GrowlMail Reviews

1.4.0b8
21 August 2014

Receive Growl notifications for incoming mail (beta).

Sitting-In-The-Sun
11 November 2010

Most helpful

I really like growl mail, been working great. However just updated this morning to 10.6.5 and now it no longer works. After software update, advised plugin had been deactivated as not compatible. Look forward to a fix soon. thanks
Like (6)
Version 1.2.2

Read 34 GrowlMail User Reviews

Rate this app:

steve-11
13 February 2015
Version 1.4.x is not compatible with the latest Yosemite Mail (8.2). It is rejected by the Mail app. Please provide an update that is Mail 8.x compatible. Thank you.
Like
Version 1.4.0b8
Kenbotwinick
22 August 2014
This version was actually released July 1st... But hey, better late than never to tell us about it.
Like
Version 1.4.0b8
Garyi
16 May 2014
I like how it crashes mail as soon as something comes in, makes ofr an exciting mail experience! (deleted)
Like
Version 1.4.0b4
Kenbotwinick
05 November 2013
Dear Santa, I've been a good boy. Depending on who you ask... Can I PLEASE have GrowlMail for Mavericks for Christmas?
Like
Version 1.3.8
2 answer(s)
PaulL3421
PaulL3421
06 December 2013
The Beta seems to work for me on Mavericks (1.4.0b): https://code.google.com/p/growlmail/downloads/list Happy Christmas!
Like
Kenbotwinick
Kenbotwinick
06 December 2013
Same here. Have been using it since it was released.
Like
hmfwic47
23 October 2013
10.9 Mavericks disables GrowlMail and deletes it.
Like
Version 1.3.8
3 answer(s)
Sjd
Sjd
27 October 2013
Yes, it is currently broken. MailPluginFix says it's able to update the UUID codes, but it appears the true fix will be a new version of GrowlMail itself.
Like
30 October 2013
Just a minor technical point, OS X does not delete GrowMail, it moves it into a folder labeled "Bundles (Disabled)".
Like
Neutralzone
Neutralzone
30 October 2013
Just a minor technical note. Mavericks does not delete GrowMail, it moves it into a folder called "Bundles (Disabled)" as OS X does with any component declared incompatible.
Like
Macinman
02 February 2013
I wanted to inform the macupdate staff that your listing is outdated, and Growlmail 1.3.5 is available from the developer's site, and 1.3.4 has a bug with autoupdate, so users can't update to the new version reliably through this release. Thanks.
Like
Version 1.3.4
Cgc
29 December 2012
GrowlMail is handy but the most recent update is detected, downloaded, and errors out with a message saying it'll try again next time it's started. It's never able to update itself...
Like
Version 1.3.4
1 answer(s)
Michael-Wenyon
Michael-Wenyon
09 January 2013
same here
Like
Shane-Smith
24 December 2012
Has anyone else been getting a incompatible message?
Like
Version 1.3.4
Cyann
18 October 2012
Since Feb you didn't fix the bug on GrowlMail which is still not working on 10.7.5. What're you waiting for???
Like
Version 1.3.3
2 answer(s)
Robby-is-on
Robby-is-on
24 December 2012
Volunteers working on software in their free time provided to you at no cost have lives, too. What's wrong with you?
Like (8)
Cyann
Cyann
24 December 2012
It seems they don't have much free time…
Like
El-Comandante
30 July 2012
No longer works under Mountain Lion 10.8 :-(
Like
Version 1.3.3
Regular-Warren
09 February 2012
I'm happy that the latest versions of GrowlMail are Lion compatible, but in my experience, the app seems to forget my chosen Display Style configuration every time I restart my Mac. Has anyone else experienced this issue?
Like
Version 1.3.3
Willowdemayo
02 February 2012
Hi. I installed the latest update, but when I launch mail it continues to deactivate the plugin. Any ideas?
Like
Version 1.3.3
steve-e
15 October 2011
Just upgraded to Mac OS X Lion 10.7.2 (11C74) and Growlmail does not work. Any idea when a compatible version of Growlmail will be available?
Like
Version 1.3.1
1 answer(s)
Clinahan
Clinahan
20 October 2011
GrowlMail 1.3.2 was just released. Updated fine via sparkle. http://groups.google.com/group/growlmail-discuss/browse_thread/thread/b37c2cada181de6b# The following issues have been addressed in this release: -- GrowlMail fails to notify on launch until you open the prefs window (#23) -- GrowlMail shuts itself down after a period of time (#24) -- GrowMail 1.3.1 doesnt work on MAC OSX LION 10.7.2 (11C74) (#25)
Like
Smactron
24 July 2011
Will GrowlMail be updated for Mac OS X 10.6.8? I won't upgrade to Lion for some time, and GrowlMail 1.2.5 only supports up to 10.6.7.
Like (2)
Version 1.3
Macmanux
23 July 2011
Yeah - 1.3 is running fin e under Lion! The original Growl developer had discontinued development, and handed over to the code of GrowlMail to the OpenSource community. And it seems, a new developer has fixed this for Lion. Many thanks, indispensable tool!
Like
Version 1.3
Myka
23 July 2011
Says here http://code.google.com/p/growlmail/downloads/detail?name=GrowlMail-1.3.zip&can=2&q= "Lion compatible version of GrowlMail, it will not work on OSes prior to 10.7.0."
Like
Version 1.3
Hkim
10 June 2011
This simply does not work under 10.6.5; nothing happens after installation and upon de-installation *then* it wants a admin password (not needed for the installation)!
Like
Version 1.2.5
2 answer(s)
Christopher-Forsythe
Christopher-Forsythe
12 June 2011
You would do good to report the issue to us instead of just to macupdates. Go to our contact page and go that route. I'm not troubleshooting this on here, it's hard.
Like
Ephg
Ephg
25 March 2012
It specifically says it is for 10.7 ONLY!!!!!
Like
Libertyforall1776
07 June 2011
http://growl.info/growlmail/version_history.php 1.2.5 ([16f468ae84e7]) Restored compatibility with PowerPC-based Macs (#218; [cfedbd755f0a])
Like (1)
Version 1.2.5
gatovadio
01 June 2011
hi people. anyone knows if it's possible to just show the %sender %subject tokens (in growlmail's prefs) in new notifications without any bit of the mail body? like just: johnny appleseed borrow cds the simplest i can get is a notification that i have a number of new emails in my inbox without any token info. thanks.
Like
Version 1.2.4
Smactron
26 May 2011
Is there a difference between "compatible with" and "declared compatibility?" The version history is inconsistent, and previous versions of the software list "Compatible with Mac OS X 10.6.x" in the changelog.
Like (1)
Version 1.2.4
1 answer(s)
Christopher-Forsythe
Christopher-Forsythe
30 May 2011
Well when we made that previous entry, we didn't fully expect them to change the uuid on every single minor update of mail.app, including the ones that only ship with new hardware.
Like
Tripod2
26 May 2011
Attempts to install GrowlMail 1.2.4 on my G5 running 10.5.8 fail with an error about being the installer being unable to write to a temp folder. Ran the GrowlMail-Installation-Fixer-1.0 app, the GrowlMail 1.2.4 installer then runs fine, yet no GrowlMail preferences are available in the Mail.app version 3.6. So now I have lost GrowlMail entirely after attempting to update. I do not have a previous version of GrowlMail installer handy to try to restore functionality.
Like
Version 1.2.4
1 answer(s)
Christopher-Forsythe
Christopher-Forsythe
07 June 2011
Try 1.2.5 now. Should be fixed.
Like (1)
Doc-Renaud
26 May 2011
Thanks, but I've already fixed it two days after the 10.6.7 release, and everything is fine. I'm glad I didn't wait for you...
Like
Version 1.2.4
7 answer(s)
Christopher-Forsythe
Christopher-Forsythe
26 May 2011
There's more than just the uuid fixes for compatibility with 10.6.7. Maybe you should read the version history before posting something like this. Chris
Like
mickaphd
mickaphd
26 May 2011
is this version works with Mail.app of Lion ? By the bye thanks to developpers : Growl and GrowlMail are perfect !
Like
Christopher-Forsythe
Christopher-Forsythe
26 May 2011
We can't comment about 10.7 until it's no longer under NDA. :)
Like
mickaphd
mickaphd
26 May 2011
@Christopher Forsythe : ok no problem ;)
Like
Doc-Renaud
Doc-Renaud
26 May 2011
Sorry, I didn't mean to sound offensive. I was just saying it took a long time for the official fix to be released. And by the way, I fully agree with mickaphd, Growl and GrowlMail are great! And free. Thanks developers :-)
Like
Christopher-Forsythe
Christopher-Forsythe
26 May 2011
No offense taken at all.
Like
TigerJohn
TigerJohn
30 May 2011
Works fine for me, two machines on 10.6.7, excellent.
Like
Hippeman
21 March 2011
Plug-in isn't compatible with OSX 10.6.7 :'(
Like
Version 1.2.3
4 answer(s)
Sitting-In-The-Sun
Sitting-In-The-Sun
21 March 2011
oh poo, I know its not growlmails fault but every update this breaks and I really like growlmail. Think I will hold off doing update to 10.6.7 for time being.
Like
Jln
Jln
23 March 2011
Works again : http://langui.sh/2011/03/21/fixing-growlmail-in-10-6-7-mail-4-5/
Like (1)
Sitting-In-The-Sun
Sitting-In-The-Sun
23 March 2011
I did the addition of the strings in the plist file and it works, go to the forum link from developers site.
Like
Christopher-Forsythe
Christopher-Forsythe
26 May 2011
It is now.
Like
HACK-Design
21 January 2011
Useful and efficient plug-in
Like (1)
Version 1.2.3
Bedouin
25 December 2010
Neat. Haven't had this in years and figured it just went away. Good to see it back.
Like
Version 1.2.3
Smactron
24 December 2010
GrowlMail 1.2.3 has been released. http://growl.info/growlmail/
Like (2)
Version 1.2.2
Sitting-In-The-Sun
11 November 2010
I really like growl mail, been working great. However just updated this morning to 10.6.5 and now it no longer works. After software update, advised plugin had been deactivated as not compatible. Look forward to a fix soon. thanks
Like (6)
Version 1.2.2
2 answer(s)
Dorkypants
Dorkypants
22 March 2011
@Jminnihan: broken again in 10.6.7 and copy-pasting the PluginCompatibilityUUID from Mail.app's Info.plist to GrowlMail's SupportedPluginCompatibilityUUIDs array didn't work.
Like
Dorkypants
Dorkypants
22 March 2011
Apparently 2 ID strings need to be added: 36555EB0-53A7-4B29-9B84-6C0C6BACFC23 1C58722D-AFBD-464E-81BB-0E05C108BE06 Thanks to Greg Welch, developer of MailFollowUp plugin for the solution.
Like
Philmac
24 September 2010
When GrowlMail gets the body of a message, it also loads images, even if you have turned off "Display remote images" in Mail's preferences. The bug is known and is slated to be addressed in version 2.0. The workaround is to select "Show a summary or received emails" in GrowlMail's preferences. (That means GrowlMail won't show the text of messages, of course.) The issue is discussed at http://groups.google.com/group/growldiscuss/browse_thread/thread/9ea4179d02aa968a/c62811c448ae6c0d If it matters to you, you can express that by starring the ticket: http://code.google.com/p/growl/issues/detail?id=89
Like
Version 1.2.2
Shane-Smith
09 July 2010
I couldn't install this on my G5 running 10.5.8. I found this on a discussion board and all worked fine after that. http://groups.google.com/group/growldiscuss/browse_thread/thread/8a0482740a729e56/b672c3b83a6dde6c?lnk=gst&q=growlmail#b672c3b83a6dde6c
Like
Version 1.2.2
Gbbob
06 July 2010
I have downloaded it 4 times deleted the last version quit mail and every time it crashes right as it begins to installs. What the hell is going on. G5 Dual 2gig cpu 3 gigs of ram ati x 8600 xp pro I don't have an earlier version which is unusual for me since I keep a separate DL folder for everything I install. I even found the program that could convert any text into usable text and I believe other medial as well. It was called CanOpener for OS 9 and earlier. It was one of the highest rated programs then. If anyone has the ability to evolve it to OS X could make some money with me. Contact me if anyone is interested by my email address gameboybob@aol.com.
Like
Version 1.2.2
Sitting-In-The-Sun
05 July 2010
just put new version, unfortunately it does not work. nothing happens.
Like
Version 1.2.2
3 answer(s)
Mark-Everitt
Mark-Everitt
05 July 2010
Same here. :(
Like
Version 1.2.2
Mark-Everitt
Mark-Everitt
05 July 2010
I quit and installed Growl Mail again and now it works. Try that. :)
Like
Version 1.2.2
Sitting-In-The-Sun
Sitting-In-The-Sun
05 July 2010
Sorry. It does work, forgot to redo the growl panel as well. Growl mail is not stand alone ! Sorry having senior moment. :-)
Like (1)
Version 1.2.2
Dorkypants
15 June 2010
After upgrading to OS X 10.6.4, Mail disabled GrowlMail as an incompatible plugin.
Like (4)
Version 1.2.1
Smactron
21 April 2010
Great, straightforward plugin. I love Growl so GrowlMail is an awesome addition.
Like
Version 1.2.1
Gitte79
20 April 2010
Great, always searched for such Mail plugin. Downloading now and see what happens. Fingers crossed. Hoping it does what it says it does.
Like
Version 1.2.1
1 answer(s)
Gbbob
Gbbob
20 April 2010
I have DL it three times and it crashes each time as it installs. I had to view the invisibles in order to just make sure the folder that it said it could not find was there and it was. Good program, crappy installer. End of Line
Like
Version 1.2.1