Safari AdBlocker
Your rating: Now say why...

(31) 4.467741935483871

64-bit ad-blocker.   Free
Add to my Watch List
Email me when discounted
Safari AdBlocker 64-bit ad blocker.
What's New
Version 1.9.8.7:
  • Fix for CPU spike when feed is unavailable
  • Fix for a rare case when trying to select a style sheet which Safari is already configured to use
  • updated included SIMBL to v0.98d
Requirements
Intel/PPC, Mac OS X 10.5 or later



MacUpdate - Safari AdBlocker



Safari AdBlocker User Discussion (Write a Review)
ver. 1.x:
(31)
Your rating: Now say why...
Overall:
(31)

sort: smiles | time
burypromote
+1

+5

Cricket99 reviewed on 29 Aug 2012
Wonderful, wonderful extension... until I upgraded to Safari 6.0. Now, many pages are incredibly slow to load, and Safari crashes constantly. Since disabling AdBlocker, my system is back to its speedy, stable self, but I greatly miss the clean looks AdBlocker provided. Hope to see an update soon!
[Version 1.9.8.7]

2 Replies

burypromote
+1

+136
Neil_m replied on 13 Sep 2012
Agreed. It makes realise how many ads I've been avoiding. Hope it gets upgraded soon.
burypromote
+1

+42
Aargl replied on 29 Sep 2012
I've just discovered that Ghostery, whose purpose is mainly to prevent tracking, is also blocking ads, so that I could disable AdBlocker. ;-)
http://www.macupdate.com/app/mac/39627/ghostery-safari-extension
I haven't tested it on Safari 6, though.
burypromote

+42

Aargl reviewed on 18 Jul 2012
Indispensable and working perfectly for me on 10.6.8!
I've been a long time SafariBlock user and tried alternatives but nothing compares to it!
I only know of Adblock Plus on Firefox that's better, but not on Safari, no, no! ;-)
[Version 1.9.8.7]


burypromote

Pool reviewed on 15 Dec 2011
I too was very happy with the old SafariBlock and disappointed that the new version didn't quite work so well. I mainly use it to block flash commercials prior to online video material and when I installed the app on 2 different iMacs (one running a dutch version of 10.7.2 and Safari 5.1.2, the other an english system version of 10.7.2 and safari version 5.1.2), the app on the english system DID work and on the dutch version didn't. Maybe it's just a system's language error...
[Version 1.9.8.7]


burypromote
+3

+36

Zincker reviewed on 29 Aug 2011
Looking forward to a working update for Safari 5.1. I've been using Glimmer Blocker since then and not quite happy with its speed. Adblocker was much better/faster loading pages IMHO and way easier to configure. Thanks.
[Version 1.9.8.7]


burypromote
+4

+13

nowheredense reviewed on 18 Jul 2011
As far as I can tell, Safari AdBlocker no longer works with Safari 5.1 (7534.48.3) on Lion GM. We desperately need a Lion update ASAP!!
[Version 1.9.8.7]

2 Replies

burypromote

+85
Mitch_de replied on 21 Jul 2011
Yep.
But i don't know if its an SIMBL (needed by the app) problem with LION or an problem with the app itself.
burypromote
+6

+269
Sweetp Productions (developer) replied on 24 Jul 2011
It's not SIMBL, Safari has updated to WebKit2, so SAB requires a rewrite. I am currently looking into an update, but don't have a lot of spare time at the moment...
burypromote
+1

+17

Jozgta reviewed on 01 Apr 2011
Have been using this for a while now and can't imagine having to do without it. Easy, efficient, low maintenance. Worth the donation.
[Version 1.9.8.7]


burypromote
+4

+4

Bcourbage reviewed on 22 Jan 2011
Excellent ad blocking extension: effective, feature rich and easy to configure. My only commentary is that using SIMBL is unfortunate now that Safari provides a framework to use extensions directly.
[Version 1.9.8.7]


burypromote
+1

+77

Doc-Renaud reviewed on 22 Jan 2011
Perfect !!!
[Version 1.9.8.7]


burypromote
+2

+85
Mitch_de commented on 14 Nov 2010
GREAT Blocker. I can celebrate the 333.333 blocked Ad :)
I had never major probs with that blocker.
Thanks to the dev
[Version 1.9.8.6]


burypromote
+1

+131
shacklaw commented on 24 Jul 2010
Just want to chime in and say I hope this extension (or whatever you want to call it) continues to be developed, as the new AdBlock extension significantly slows Safari down. The other true extension, AdStopper, isn't as slow, but does not allow any configuration at all.

Until AdBlock gets better performance, or something better is released, I'll continue to use this, despite Safari's extension support.
[Version 1.9.8.6]

2 Replies

burypromote

+605
Fishscale commented on 08 Aug 2010
This developer makes only two plugins. This one and safari cookies. Adblock the safari 5 extension is made by someone else. It actually is customizable if you click the button that appear in your toolbar after you double click and install adblock the extension. I don't think you have to worry about support being dropped for this as this dev has nothing to do with adblock the extension for safari 5. Adblock the extension is made by Michael Gundlach. Hope that helps.

I also am a fan of this plugin as well as safari cookies (same dev, as I said.)

Mr. Russell Gray - Thank you!
burypromote
+1

+131
shacklaw replied on 12 Aug 2010
I know he has nothing to do with the AdBlock extension developer. However, I always see on the 'net that this plugin is now obsolete because AdBlock is the best thing ever. It's not--it renders Safari to beachball all the time. Basically, Safari becomes useless. Also, try using Google Maps streetview with the AdBlock extension.

So, what I meant to say was, until AdBlock actually becomes what I consider usable, I hope the developer of this plugin doesn't assume everyone's switched over and stop developing it.

Keep up the good work, Mr. Grey.
burypromote
Camberol had trouble on 21 Nov 2010
Apologies for the error outlined immediately below. The error loading yahoo.com occurs because of the inclusion of the filter: *yimg.com*. Elimination of this rule prevents the error entirely.
[Version 1.9.8.6]


burypromote
Camberol had trouble on 19 Nov 2010
Safari 5.0.3 will not load Yahoo.com properly unless Safari AdBlocker 1.9.8.6 is turned off.
[Version 1.9.8.6]


burypromote

+177
Stormchild had trouble on 23 Oct 2010
Manually-added filters are no longer working (in Safari 5.0.2).
[Version 1.9.8.6]


burypromote

+177
Stormchild had trouble on 23 Oct 2010
Manually-added filters are no longer working (in Safari 5.0.2).
[Version 1.9.8.6]


burypromote
-1

+4
Killsapo had trouble on 28 May 2010
The latest versions are not making work at all some favelets I have installed on the menu bar (i.e. friendfeed, bit.ly)... any ideas?
[Version 1.9.8.2]


burypromote

+13
Sv1223 had trouble on 21 May 2010
Safari AdBlocker v1.9.8.1 is blocking all the pictures when I browse Wikipedia.
[Version 1.9.8.1]

1 Reply

burypromote
+1

+269
Bollywood (developer) replied on 21 May 2010
I have fixed this in my latest beta build here:
http://www.facebook.com/pages/Safari-AdBlocker/397912771070

direct d/l:
http://sweetpproductions.com/safariadblocker/Safari_AdBlocker_1.9.8.2c.zip
burypromote
+3

+12
Cyann had trouble on 12 May 2010
Again could you tell me why update never works?
Each time I've to desinstall and reload the new version.
[Version 1.9.7]

5 Replies

burypromote
+1

+59
Mindsnare replied on 12 May 2010
same here. it loads, then it tells me the update has failed
burypromote

+36
Fotodivr commented on 13 May 2010
If you are having this problem, you may want to repair permissions then install.
Just a thought... I don't seem to have the problem you are having.
burypromote
+2

+59
Mindsnare replied on 14 May 2010
This is not a permission problem at all. You can repair the hell out of it, without the slightest effect on sparkle failing.
burypromote

+12
Cyann commented on 14 May 2010
Any idea to solve this problem Mister Bollywood?
You've answered to all the comments except this one…
burypromote
+1

+269
Bollywood (developer) replied on 14 May 2010
Theres not a lot I can do about it, it seems to be a problem with Sparkle, the update framework.
burypromote

+88
R0n1n had trouble on 11 May 2010
After upgrading to 1.9.6 safari started to take a little longer to start, so I tried a reset. which didn't help so I opened up console and noticed the following odd error.

5/11/10 12:53:51 AM Safari[815] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary.

This error shows up in console every time I launch safari. I assumed it was SAB (1.9.6), so I downgraded back to 1.9.5 and the error no longer shows up in console and safari start up speed returned to normal.
[Version 1.9.6]

5 Replies

burypromote
+1

+80
Weaselboy replied on 11 May 2010
I see the same console log entry with 1.9.6, but it does not seem to effect Safari speed at all for me.
burypromote
+2

+85
Mitch_de replied on 11 May 2010
I dont have speed negatives with 1.9.6 - the oposite happend: more speed rendering sites with lots of content. (I use the default 2 blocklists).
burypromote
+3

+269
Bollywood (developer) replied on 11 May 2010
Ive fixed it.
its not super important, so ill sit on it a little, and see if any other bugs pop up. it is available here though if anyone wants it:
http://www.facebook.com/pages/Safari-AdBlocker/397912771070
or direct link:
http://sweetpproductions.com/safariadblocker/Safari_AdBlocker_1.9.6.2.zip

a very simple fix, just time consuming...
it was actually a missing ";" from one of the header files in the RegexKit framework.

found from this link:
http://oddeye.blogspot.com/2008/11/regexkitframework.html
burypromote
+1

+80
Weaselboy replied on 11 May 2010
That fixed it. Thanks for the quick response Bollywood.
burypromote
+1

+88
R0n1n replied on 11 May 2010
@Bollywood. Wow, that was quick! Safari's start speed returned to normal and the console error is fixed. Thanks for the speedy updates.
burypromote

+12
Cyann had trouble on 05 May 2010
Update never works on PPC 10.5.8
Each time I have to download the new version everywhere else.
When I try to do it by your way, it tells me an error occures.
[Version 1.9.4]


burypromote

+9
Katuzero had trouble on 04 May 2010
.com.apple.Safari[23575] objc[23575]: Class SUHost is implemented in both /Library/Application Support/SIMBL/Plugins/Safari AdBlocker.bundle/Contents/MacOS/../Frameworks/Sparkle.framework/Versions/A/Sparkle and /Library/Application Support/SIMBL/Plugins/Safari Cookies.bundle/Contents/MacOS/../Frameworks/Sparkle.framework/Versions/A/Sparkle. One of the two will be used. Which one is undefined.
[Version 1.9.3]



ElTarlo rated on 12 Jul 2012

[Version 1.9.8.7]



+15

Quiiick rated on 05 Feb 2012

[Version 1.9.8.7]



Memtimen rated on 25 Jan 2012

[Version 1.9.8.7]



+4

n@ncy rated on 25 Dec 2011

[Version 1.9.8.7]



Tot54 rated on 10 Dec 2011

[Version 1.9.8.7]



+7

Lookky rated on 27 Jul 2011

[Version 1.9.8.7]



-24

widethtripp rated on 21 Jun 2011

[Version 1.9.8.7]


Downloads:123,610
Version Downloads:57,179
Type:Internet : Plug-ins
License:Free
Date:22 Jan 2011
Platform:PPC 64 / PPC 32 / Intel 64 / Intel 32 / OS X
Price:Free0.00
Overall (Version 1.x):
Features:
Ease of Use:
Value:
Stability:
Displaying 1-10 of 115
1 2 3 4 5 6 7 8 >
Displaying 1-10 of 32
1 2 3 4 >
Displaying 1-7 of 7
-
-
-
Please login or create a new
MacUpdate Member account
to use this feature
Watch Lists are available to
MacUpdate Desktop Members
Upgrade Now
Install with MacUpdate Desktop.
Save time moving files & cleaning
up space wasting archives.
Safari AdBlocker 64-bit ad blocker.


- -