ATI Radeon HD 2600 XT Firmware Updater
Your rating: Now say why...

0

For Mac Pro computers with ATI Radeon HD 2600 XT graphics.   Updater
Add to my Watch List
Email me when discounted
ATI Radeon HD 2600 XT Firmware Updater... This update is for Mac Pro computers with one or more ATI Radeon HD 2600 XT graphics cards installed, running Mac OS X 10.5.2 or later with the Leopard Graphics Update.

It updates the ATI Radeon HD 2600 XT graphics card firmware on all of the ATI Radeon HD 2600 XT graphics cards in the Mac Pro to improve system stability.
Requirements
Intel, Mac OS X 10.5.2 or later, Leopard Graphics Update.






ATI Radeon HD 2600... User Discussion (Write a Review)
ver. .x:
Your rating: Now say why...
Overall:

sort: smiles | time
burypromote

+4
Ferruccio Busoni commented on 11 Mar 2008
Does not fix the restart-on-wake-from-sleep issue (just happened), but it does fix graphics glitches and allegedly the screen freeze issue.
[Version ]


burypromote
Crunch Hardtack commented on 10 Mar 2008
This update fixed the OS-level flickering of some buttons and menus I was having after I updated my Mac Pro (2008) to 10.5.2.
[Version ]


burypromote
Uelef commented on 10 Mar 2008
I bought the 2600 XT at the Apple online store. It's the same graphic card you can buy for the new Mac Pros, but it also works on older Mac Pros.
There are many graphic issues reported by users of the 2600 XT on both Mac Pros (old and new). Now Apple apperently is fixing them with the firmware updater. But on my old Mac Pro the updater does not work. It's says that the firmware update is not necessary. And that's what I am complaining about... You need a new Mac Pro to run the updater.
[Version ]


burypromote

-25
FvdG commented on 10 Mar 2008
Indeed: does not update the card if it is in an 'old' Mac Pro (quad 2.66 Ghz)!!!
[Version ]


burypromote
Uelef commented on 10 Mar 2008
The Radeon HD 2600 XT works on my 1st generation Mac Pro - but the firmware update does unfortunately not... That's no good!
[Version ]

3 Replies

burypromote

+60
qb replied on 10 Mar 2008
Are you sure you MP needs it? According to MacTracker the original MP never had an option for this video card. Unless you bought and added one later you don't need this therefore your "not good"
burypromote
Uelef replied on 10 Mar 2008
Yes, I guess, that's the reason, why I cannot install the firmware update. Sometimes Apple is so annoying... They do not let me use the Radeon 2600 XT on my old Mac Pro although it works (but unfortunately with graphic issues)...
burypromote

+60
qb replied on 10 Mar 2008
I'm still confused - are you saying you DID buy and add the card to your MacPro? And that there are video issues. If this is the case then it is not Apple you need to gripe about. Contact the maker (ATI) and see if there is an upgrade or if your card is defective.
There are currently no troubleshooting comments. If you are experiencing a problem with this app, please post a comment.

There are currently no ratings. Write a comment or review now.

Downloads:6,166
Version Downloads:6,162
Type:Multimedia Design : Video
License:Updater
Date:10 Mar 2008
Platform:Intel 32 / OS X
Price:Free0.00
Overall (Version .x):
Features:
Ease of Use:
Value:
Stability:
Displaying 1-5 of 5
-
-
-
Please login or create a new
MacUpdate Member account
to use this feature
Watch Lists are available to
MacUpdate Desktop Members
Upgrade Now
Install with MacUpdate Desktop.
Save time moving files & cleaning
up space wasting archives.
ATI Radeon HD 2600 XT Firmware Updater... This update is for Mac Pro computers with one or more ATI Radeon HD 2600 XT graphics cards installed, running Mac OS X 10.5.2 or later with the Leopard Graphics Update.

It updates the ATI Radeon HD 2600 XT graphics card firmware on all of the ATI Radeon HD 2600 XT graphics cards in the Mac Pro to improve system stability.


- -