Castle-Combat
Castle-Combat
0.8.1

0.0

Castle-Combat free download for Mac

Castle-Combat

0.8.1
24 June 2006

Castle-building arcade game.

Overview

What is Castle-Combat?

It is a clone of the old arcade game Rampart. Up to four players (or more in future versions) build castle walls, place cannons inside these walls, and shoot at the walls of their enemy(s). If a player cannot build a complete wall around one of his castles, he loses. The last surviving player wins.

What's new in Castle-Combat

Version 0.8.1:
  • Simple single-player mode
  • Conquer mode is back
  • Fullscreen and Sound can be turned on/off
  • Better netcode
  • As always: a lot of small improvements, fixes and clean-ups

Join over 500,000 subscribers.

Subscribe for our newsletter with best Mac offers from MacUpdate.

4 Castle-Combat Reviews

Rate this app:

Pedro-Fardilha
16 October 2005

Most helpful

Doesn't work for me. Keep getting this error: ImportError: Failure linking new module: : dyld: /Users/USER/Downloads/Castle-Combat.app/Contents/MacOS/Castle-Combat Undefined symbols: /Users/USER/Downloads/Castle-Combat.app/Contents/Resources/Python/lib-dynload/AppKit/_AppKit.so undefined reference to _NSAccessibilityActionDescription expected to be defined in AppKit /Users/USER/Downloads/Castle-Combat.app/Contents/Resources/Python/lib-dynload/AppKit/_AppKit.so undefined reference to _NSAccessibilityRoleDescription expected to be defined in AppKit /Users/USER/D
Like
Version 0.8
Pedro-Fardilha
16 October 2005
My apologizes, Somehow I didn't noticed that it was only for 10.4. I'm using 10.3.9. since 10.4 freezes my dual G5.
Like
Version 0.8
3 answer(s)
Karl Bartel
Karl Bartel
17 October 2005
No problem. If you like, you can try the build at ser.cs.tu-berlin.de/~karlb/castle-combat/Castle-Combat.app.zip , which should have fixed that particular problem. But I'm not sure that it's the only problem since I don't have a 10.3 installation at hand to verify.
Like
Version 0.8
Karl Bartel
Karl Bartel
17 October 2005
The link should be: http://user.cs.tu-berlin.de/~karlb/castle-combat/Castle-Combat.app.zip
Like
Version 0.8
Anonymous
Anonymous
18 October 2005
I was having the same problem, and just downloaded the version you linked. It now works perfectly. Thanks!
Like
Version 0.8
Anonymous
16 October 2005
Downloaded it, unzipped it, and launched the app successfully on a new PowerBook running 10.4.2
Like
Version 0.8
Anonymous
16 October 2005
I get the same error message as the previous poster when attempting to open the download.
Like
Version 0.8
1 answer(s)
Karl Bartel
Karl Bartel
16 October 2005
Did you get the file "Castle-Combat-0.8.0.app.zip"? For a short time a false version was linked from my site. Are you running Mac OS 10.4? Thanks, Karl
Like
Version 0.8
Pedro-Fardilha
16 October 2005
Doesn't work for me. Keep getting this error: ImportError: Failure linking new module: : dyld: /Users/USER/Downloads/Castle-Combat.app/Contents/MacOS/Castle-Combat Undefined symbols: /Users/USER/Downloads/Castle-Combat.app/Contents/Resources/Python/lib-dynload/AppKit/_AppKit.so undefined reference to _NSAccessibilityActionDescription expected to be defined in AppKit /Users/USER/Downloads/Castle-Combat.app/Contents/Resources/Python/lib-dynload/AppKit/_AppKit.so undefined reference to _NSAccessibilityRoleDescription expected to be defined in AppKit /Users/USER/D
Like
Version 0.8
1 answer(s)
Karl Bartel
Karl Bartel
16 October 2005
Did you get the file "Castle-Combat-0.8.0.app.zip"? For a short time a false version was linked from my site. Are you running Mac OS 10.4? Thanks, Karl
Like
Version 0.8