Thank you for your review
Developer website: 

Top community discussions about VET-1 Synthesizer

The VET-1 freeware softsynth is a barebones virtual noisemaker endowed with some weird detuning features. It was originally released in 2002 for the Mac OS 9 version of Pluggo; three years later the thing is back, ready to run on OS X.

  • compatible with Pluggo Runtime 3.5.2 (Cycling 74)
  • suitable for use with ProTools, Cubase, Logic, Digital Performer and programs like the VSTi Host 3.12X (Defective Records) running on OS X Tiger

Requirements for VET-1 Synthesizer

OS X 10.1 or later, or OS 9, Cycling 74 Pluggo Runtime, any audio host application allowing for virtual instrument plug-ins.
Similar Software
Suggest other similar software
Create a collection and add  to it.
Like this app? Be the first to add it to a collection! Create a Collection by bringing together complementary apps that have a common theme or purpose, then share it and discover new collections! + Create a Collection

VET-1 Synthesizer User Discussion

Ratings
Overall
(0)
Current Version (2.x)
(0)
Details
Downloads 2,643
Version Downloads 1,997
License Free
Date 28 Sep 2005
Platform OS Classic / OS X / PPC 32
Price Free
To leave a comment, you need to be logged in.
reviews_anchor
Sort by: Time | Smiles
VET-1 Synthesizer needs a rating. Be the first to rate this app and get the discussion started!
MacUpdate Promo