5
Thank you for your review
Free
http://www.macupdate.com/download/7294/php-5.5.15.tar.bz2
Email me when discounted: 

This is a PHP module for the Apache Web server included in OS X. PHP is a server-side, cross-platform scripting language. PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML. MacUpdate is created using PHP language.

What's New

Version 5.5.15:

CLI server:
  • Fixed bug #67429 (CLI server is missing some new HTTP response codes).
  • Fixed bug #66830 (Empty header causes PHP built-in web server to hang).
Core:
  • Fixed bug #67428 (header('Location: foo') will override a 308-399 response code).
  • Fixed bug #67436 (Autoloader isn't called if two method more...

Requirements

OS X 10.1 or later

Similar Software

Open Comparison
Suggest Other Similar Software
Leave a Review

PHP User Discussion

Nobody has reviewed or commented on this app yet. Add your own comment and get a discussion going!
Sort by: Time | Smiles
g.peretz Member IconComment+3
g.peretz
+1

Why o why does MacUpdate track Unix software in the main Mac software channel? Just a suggestion, but i would prefer it if you had a separate tab/category for server software, daemons, CLI utilities and the like. That way, the 90% who don't use it won't have to contend with the added entries on the tracker. (I do personally use a lot of server-oriented software and CLI tools, so i would personally check that category for updates. But my preference would be to separate them out to another category listing.)

Reply0 replies
Version 5.5.6
Neil_m Member IconComment+179
Neil_m
+2

From the developers website;
Note: The package on this page is outdated. I recommend this new PHP distribution for Mac OS X, it is based on mine:
http://blog.liip.ch/archive/2011/04/13/php-5-3-for-os-x-10-6-one-line-installer.html

http://php-osx.liip.ch/ - is the best source for a 10.6 version of php.

Reply0 replies
Version 5.3.0-3
Schmelding Member IconComment+151
Schmelding
+0

Since Snow Leopard wiped-out my install of the entropy version of PHP, does anybody know what would happen if I reinstalled this?

Reply2 replies
Version 5.3.0-3
Neil_m
+0

go to Marc's forum and ask - sure you will get a good thorough answer.

Tuscan69
+0

i just installed this on 10.6.2, and now i cannot access any of my local pages anymore. "Network Error (tcp_error) - A communication error occurred: Connection refused"

neil_m Member IconComment+179
neil_m
+0

Now PHP 5.3.0-3

Thanks Marc for compiling this for OS X - it gets me an easy way to get an upto date php distro, with GD (not on Apple's vanilla inbuilt), etc. onto my server - without waiting, waiting for Apple to update.

Reply0 replies
Version 5.3.0-3
Brian-Kendig Member IconComment+39
Brian-Kendig
+0

The current version at http://www.entropy.ch/software/macosx/php/ is 5.2.4.

This is the same version as the PHP that ships with Leopard, so there's currently no reason to try installing this on Leopard.

Reply0 replies
Version 5.2.2
VGZ Member IconComment+8
VGZ
+0

Warning, if you require PHP DO NOT upgrade to Leopard. This PHP installation will not work on Leopard. Hopefully an update will be made available by the developer soon.

Reply2 replies
Version 5.2.2
tshawkins
+0

You don't need this for leopard, it already has php 5.2.2 installed by default, you just need to activate it by copying the php.conf file into the right place. Tiger also has php 4.3 installed by default, again it just needs activating to run.

Neil_m
+0

But the Apple install lacks additions like the GD library.

DPoncy Member IconComment+13
DPoncy
+0

I installed this package (OS 10.4.10 and Apache 1.3) and now Apache fails.

How do you uninstall this?

Reply2 replies
Version 5.2.1
MacUpdate-Lon
+0

Perhaps you should post your question to the developer's user forum:

http://www.entropy.ch/phpbb2/

theblackcrow
+0

hi,
if got the same error an do the following:

go to the directory: /etc/httpd/sites and delete the file: +entrophy-php.conf

before i delete the file, i insert the LoadModule an the AddModule statment in the httpd.conf. so you can enable / disable the php5 module via Admin Server.

When i enable both PHP5 and PHP4 my server crsh with a Bus Error.

cu

carla2 Member IconComment+0
carla2
+0

Never said it, but have used your builds and tips for so long that it's way overdue: Thank you, Marc.

Reply0 replies
Version 5.2.1
dolphin55 Member IconComment+0
dolphin55
+0

Hi, I got same error under the OSX server 10.4.8 when I try to upgrade from PHP5.0.1.

Reply0 replies
Version 5.2.1
Brian-Kendig Member IconComment+39
Brian-Kendig
+0

Note that this package will ONLY work on Mac OS 10.4, NOT 10.3! I installed it on 10.3 and the installation failed at the end, and then the Apache server would not restart because it could no longer load the php shared library. I can't find any precompiled version of PHP 5.2 available for Mac OS 10.3.

Reply4 replies
Version 5.2.1
MacUpdate-Lon
+0

The stated requirements on the product page: Mac OS X 10.4 or later.

Brian-Kendig
+0

I missed that because previous PHP 5 packages have installed on 10.3. This installer attempts to install on 10.3, but fails at the end. The developer's site states that "older, unmaintained, unsupported, ppc-only packages of PHP 5 are available for Mac OS X 10.3", but I can't find any linked from that site. So, user beware.

Brian-Kendig
+0

Aha, the previous version is still available at:

http://www2.entropy.ch/download/entropy-php-5.1.4-5.tar.gz

MacUpdate-Lon
+0

Thanks, I will post that in the 'Related Links' section of the PHP product page here at MU... thanks again.

user icon+0
BlakeC6588
Version 5.5.3
user icon+23
Sparrowhawk
Version 5.5.3
user icon+0
olamaekle
Version 5.5.1
> 5 9

Ratings

Overall
(9)
Current Version (5.x)
(5)

Details

Downloads 42,148
Version Downloads 91
Type Internet / Servers
License Free
Date 28 Jul 2014
Platform OS X / PPC 32 / Intel 32
Price Free