0
Thank you for your review
Free
http://www.macupdate.com/download/14044/e-uae_0.8.29-wip4_macosx-ppc_sdl.dmg.gz
Email me when discounted: 

(SDL)uae is a new version of the popular Amiga emulator (UAE).

This 'experimental' version of UAE is aimed at bringing all the cool features of WinUAE to non-Windows platforms. It incorporates the lastest CPU and custom-chip emulation from WinUAE, a bunch of bug-fixes, and I am gradually implementing for other platforms all those neat features that WinUAE offers. Linux, OS X, AmigaOS and BeOS are all currently supported with varying degress of functionality, although UAE should build and run on any Unix-like system.

What's New

Version 0.8.29-WIP4:
  • Here at last. Lots of bug fixes, better performance and an experimental OpenGL renderer in the SDL back-end - which, incidentally, makes E-UAE fly on Mac OS X.

Requirements

  • Mac OS X 10.2 or later
  • SDL library

Similar Software

Open Comparison
Suggest Other Similar Software
Leave a Review

E-UAE User Discussion

Nobody has reviewed or commented on this app yet. Add your own comment and get a discussion going!
Sort by: Time | Smiles
gatovadio Member IconComment+0
gatovadio
+0

the amiga will never die:
http://fengestad.no/wp/fs-uae

Reply0 replies
Version 0.8.29-WIP4
Anonymous Member IconReview
Anonymous
+0

Bringing the winuae features to other platforms... that's GREAT news :) I was so disappointed to see winuae take its own direction, instead of including portable code. I would have fixed that myself if I could, so it's great to see someone doing it :D Thanks!! :D

Reply0 replies
Version 0.8.27rc2
Anonymous Member IconReview
Anonymous
+0

it looks like an amiga.

Reply1 reply
Version 0.8.27rc2
Geoff
+0

Hi,
I have the Kickstart Rom & Workbench, but cannot get this emulator to work for love nor money. Could someone please explain how this is done?
Thanks

Anonymous Member IconReview
Anonymous
+0

could we see a screenshot please?

Reply0 replies
Version 0.8.27rc1
Anonymous Member IconReview
Anonymous
+0

ok, blame over my head! ;-)

with Version 0.8.25 fink, (with installed X11(tricky to configure), and "fink"-installed libsdl and gtk+ and gtk+2) also the bsdsocket.library runs the first time for me under Mac OS X, inclusive GUI! (under X11)!

Congratulations to the programmer! :-)

There are still different configure-options in documentations and emu, I would recommend the programmer, to descide to support the WinUAE options-syntax to stay compatible there and make a big differnce to the dead MaxUAE! Then the success will be!

Reply1 reply
Version 0.8.23-20040223
Richard Drummond (Developer)
+0

Hi Anonymous

You wrote:
> installed libsdl and gtk+ and gtk+2)

Actually, the Fink version is currently built against Gtk+ 1.2 (you don't need to install gtk+2). I shall probably change this to using Gtk+ 2 in future. Who knows - there may even be a native OS X GUI one day. ;-)

> Congratulations to the programmer! :-)

Thanks.

> descide to support the WinUAE options-syntax to stay compatible there

It is already compatible. Apart from a few platform-specifc options, the config options are identical to WinUAE - it uses the same source code for parsing config options. The documentation is out of date.

Cheers,
Rich

Anonymous Member IconReview
Anonymous
+0

b.t.w.: eg. in the manual it reads: "bsdsocket_emu=true" and not "bsdsocket_emu=yes". Thats a typical UAE-phenomenon, that one says that, the other that... no stable documentation and no stable "compatibility b.t.w. descision" to configfiles.

Reply3 replies
Version 0.8.23-20040221
Richard Drummond (Developer)
+0

Hi

I'm the maintainer of this application - although I didn't post this listing here and I didn't come up with the name SDLuae. I'm not terribly happy with either - or the fact the version posted here was a test version, not meant for public release.

It you want to find the latest full release, the go to http://www.rcdrummond.net/uae/.

You will find there that there are two versions for OS X, one built against the Fink and one for the regular OS X version of SDL. Using the latter will cure the problem 'dyld: /Applications/SDLuae can't open library: /sw/lib/libSDL-1.2.0.dylib'
reported below.

Yes, this version of UAE isn't perfect. I have called it "Experimental" for good reason.

Anonymous wrote:
> no stable documentation

On the contrary, the documentation is incredibly stable. It hasn't been updated in years. Why not help update it?

> and no stable "compatibility b.t.w. descision" to configfiles.

I have no idea what that means. The config files are meant to be compatible with WinUAE config files. Is that a problem?

Cheers,
Rich

MacUpdate-Lon
+0

Link to newest version mentioned by the dev has been posted to this MU page (02/24/2004)

Anonymous Member Icon
Anonymous
+0

Thanks MU Admin & thanks Rich. I might be able to rescue some old work I did years ago -- not everyone used their Amiga for playing games (so why is this under "games" not "emulation"?)

Anonymous Member IconReview
Anonymous
+0

Not, that i'm currently own a lot of knowledge of programmers, but i think here's propagated a big fault. On his webpage we can definitively see, that the bdsocket.library only works with Linux and WinUAE, but not at this time with MacOS X, especially nor without X11-Fink stuff.

I don't knwo why, but a all time repeatedly strategy of Amiga-Users is to propagate things, that never or only with a few years delay gonna work.

Except this thing, SDL-uae works on my iMac. (I putted it into the MaxUAE Package (placed MaxUAE with sdluae (renamed to "MaxUAE") and it works not bad. True the TCP/IP Stack seems to claim ports, but nothing is working, wether iBrowse nor AWebII) its good for games at this state, nothing less, nothing more.

The most important thing for the programmer will be to "not leave" the path of staying compatible to the WinUAE or the classic UAE in any way, to ensure that the commands and the fictive GUI's will getting "stable"

Reply0 replies
Version 0.8.23-20040221
Anonymous Member IconReview
Anonymous
+0

How the heck do I get this thing working ? I installed the SDL Library and I get this error message:
dyld: /Applications/SDLuae can't open library: /sw/lib/libSDL-1.2.0.dylib (No such file or directory, errno = 2)
Trace/BPT trap

What do I have to do to get it working ?

Reply0 replies
Version 0.8.23-20040221
There are no Ratings for this App yet.
> 0 0

Ratings

Overall
(0)
Current Version (0.x)
(0)

Details

Downloads 14,238
Version Downloads 4,023
License Free
Date 27 Mar 2007
Platform OS X / PPC 32
Price Free
Learn how MacUpdate Desktop makes installing apps from MacUpdate.com one-click easy.
Next time, install E-UAE with 1-click

Learn how MacUpdate Desktop can install apps on MacUpdate with the simple click of the Install apps with MacUpdate Desktop icon. Plus, keep all your apps updated.