1
Thank you for your review
$10 00
http://www.macupdate.com/download/10752/pithhelmet-3.0b6.pkg
Email me when discounted: 
PithHelmet... Problem: I hate ads. Solution: Kill my television. Better Solution: Content-filter my Web pages...

The PithHelmet adds some basic but powerful content filtering to Apple's Safari browser. The basic purpose is to filter advertisements, but there are other potential uses as well (blocking Flash, Shockwave or horrible midi loops).This is just a quick hack on top of Apple's basic framework, but it seems to work rather effectively.

What's New

Version 3.0b6: Release notes were unavailable when this listing was updated.

Requirements

Mac OS X 10.4 or later, Safari 3.2, SIMBL.

Similar Software

Open Comparison
Suggest Other Similar Software
Leave a Review

PithHelmet User Discussion

Nobody has reviewed or commented on this app yet. Add your own comment and get a discussion going!
Sort by: Time | Smiles
Harv Member IconComment+340
Harv
+3

Might someone know if PH will be updated for Lion compatibility? And with AdBlock and the like, is it even necessary?

Reply2 replies
Version 3.0b6
Cowicide
+0

This appears to be abandonware @ this point.

Cowicide
+0

And, on that note, one should use Extensions with Safari nowadays like the wonderful donationware, Safari AdBlock:

http://macupdate.com/app/mac/26171/safari-adblock

Smactron Member IconComment+76
Smactron
+1

Is this compatible with the newly-released Safari 5.0.3?

Reply0 replies
Version 3.0b6
Smactron Member IconComment+76
Smactron
+2

Is PithHelmet 3.0b6 fully compatible with Safari 5.0.2? If so, I hope the developer releases another beta update soon with updated version compatibility strings so that end users can just run the updated installer instead of needing to mess around with plist files.

Reply0 replies
Version 3.0b6
Jambaman Member IconComment+1
Jambaman
+1

I went thru the installation process MANY TIMES!

Each time, installation was 'successful', for both SIMBL, and Pithhelmet.

Neither SIMBL or Pithhelmet can be found!!
Can't be opened either of course!!!!!!!!!!!!!!!

I am using snow leopard mac os x.

Anyone know why this is.

Reply0 replies
Version 3.0b6
Smactron Member IconComment+76
Smactron
+2

The developer doesn't have a comprehensive or frequently-updated blog so I was wondering if anyone know if he had plans to make this into a Safari Extension now that Safari 5.0.1 is out.

Reply2 replies
Version 3.0b6
Smactron
+1

I emailed the developer asking him this question and he said no.

Cowicide
+0

I guess this is dead then?

Would the developer care to confirm or counter this and give us all who donated money some info please?

Harv Member IconComment+340
Harv
+2

While the above indicates the latest Beta is 3.0b3, a visit to the developer's site indicates it is 3.0b6 (as of 23 June 10).

FWIW: On my C2D Intel iMac, OS 10.6.4, I have found the DL and install without issue, though Safari must still be run in 32-bit mode.

Aside from that, no problems yet detected.

Reply0 replies
Version 3.0b3
sjk Member IconComment+994
sjk
+2

http://www.culater.net/software/PithHelmet/PithHelmet.php says:

PithHelmet 3 now works with both Safari 4 and 5 running on both Leopard and Snow Leopard.

• SIMBL-0.9.x (install first)
• PithHelmet-3.0b6.pkg (released 2010-06-23)

But if SIMBL-0.9.x (0.9.7a) still requires Snow Leopard then how can PH now work on Leopard?

Reply3 replies
Version 3.0b3
sjk
+1

Developer (Mike) says PH 3.0b6 works for Safari 5 with either SIMBL 0.8.x or 0.9.8 on Leopard. Got it working fine with 0.9.8 on my iMac G5. Might eventually switch to the AdBlock extension but I'm satisfied with this for now. Thanks, Mike!

Cowicide
+0

It's frustrating stuff like this that's making me desperately try to find another ad blocker. I don't understand how you can say it works with 10.5 when the simbl installer says it's on 10.6 compatible.

This makes NO SENSE.

sjk
+0

Stating it's *compatible* with 10.6 isn't the same as stating it *requires* 10.6.

Smactron Member IconComment+76
Smactron
+2

For what it's worth, when you install PithHelmet 3.0b4 and go to the "About PithHelmet…" menu bar item, it reports its version as 3.0b3.

Reply0 replies
Version 3.0b3
sjk Member IconComment+994
sjk
+2

Reposting a variation of the question I've recently asked the developer:

Anyone know if it's currently possible to use PithHelmet with Safari 5 on Leopard (PPC) systems?

Seems that's (still) an unsupported combination but maybe I've overlooked something.

Reply0 replies
Version 3.0b3
Macolyte Member IconReview+55
Macolyte
+2

Though it isn't here on Mac Update yet, the Safari 5 iteration Of PithHelmet 3 is available on the developer's site and works like the charm it is.

I have been running PitHelmet for many years. Many years. It is hands down the most effective and manipulable content filter I've ever found. Yes, I've used Safari AdBlocker, and it doesn't come close. With PithHelmet I can seen absolutely nothing but the content I want to see on any site. Or, I can choose to see all of the ads, or all of a particular kind of ad. It's genius.

With each Safari whole digit upgrade, theres a brief pause in PithHelmet availability while Mike does his magic to make everything compatible, and each time, I am stunned by the ad content on sites I visit regularly.

No, I don't like this advertising paradigm on the internet. If I need to pay for access to content, I figure I can make that choice - and do, when the content provider lets me decide. I don't watch much broadcast tv, either.

Reply0 replies
Version 3.0b3
There are no Ratings for this App yet.
> 5 108

Ratings

Overall
(108)
Current Version (3.x)
(1)

Details

Downloads 92,356
Version Downloads 4,960
License Shareware
Date 30 Jun 2010
Platform OS X / PPC 32 / Intel 32
Price $10.00
Learn how MacUpdate Desktop makes installing apps from MacUpdate.com one-click easy.
Next time, install PithHelmet with 1-click

Learn how MacUpdate Desktop can install apps on MacUpdate with the simple click of the Install apps with MacUpdate Desktop icon. Plus, keep all your apps updated.